Hyper-V: Virtuelle Server starten nicht (mit Netzwerk) (Update) | Hyper-V Server Blog

Hyper-V: Virtuelle Server starten nicht (mit Netzwerk) (Update)

Gestern Abend gegen 18 Uhr hatten wir das Problem, das ein virtueller Server nicht mehr erreichbar war (eine Firewall, deswegen war noch mehr nicht erreichbar). Nach einem Neustart des Hostes fuhren alle virtuellen Maschinen hoch, außer die Firewall. Wenn man in den Einstellungen die Netzwerk-Verbindung auf “Nicht verbunden” setzt, konnte die Maschine gestartet werden, sobald aber eine Verbindung erstellt wurde, kam es zu einem Fehler. Wir haben dann in einer Nacht-Aktion die virtuellen Server auf dem System umgezogen und nebenbei nach einer Ursache für das Problem gesucht. Ein Tip war ein Update des Anti-Viren-Programmes, was bestimmte Dateien fälschlicherweise als “positiv” erkennt und sperrt/löscht (das gleiche Problem bei Clients hatten wir vor ein paar Monten bei einem unserer Kunden), aber ganz sicher waren wir uns nicht.

Ich habe gerade im Blog von Ben Armstrong (Virtual PC Guy’s Weblog) einen Beitrag gefunden zum Thema “Antivirus and Hyper-V“. Entweder hatte Herr Armstrong das gleiche Problem, oder hat schonmal vorab vor einem möglichen Problem gewarnt. Zeitlich gesehen ist der Beitrag um 3:05 PM erschienen, das wäre bei uns 23:05.

So wie es also aussieht scheint es das AntiViren-Programm gewesen zu sein, das Probleme gemacht hat. Leider waren wir zu sehr damit beschäftigt das Problem zu lösen, von daher haben wir keine Screenshots von der genauen Fehlermeldung gemacht. Die Fehlermeldung sagte aber aus, das Hyper-V Probleme beim Zugriff auf die NIC (VMBus, nicht emuliert) hatte. Das Anlegen einer neuen Maschine (mit Netzwerk) brachte den gleichen Fehler.

Update:

So wie es aussieht hat Ben Armstrong auf meinen Beitrag / meinen Kommentar in seinem Blog reagiert mit einem neuen Beitrag seinerseits, in dem unter anderem folgender Link aufgeführt wird:

Creating or starting a Hyper-V virtual machine on Windows Server 2008 or Microsoft Hyper-V Server 2008 may fail with error: 0x800704C8

Bingo, genau dieser Beitrag trifft’s auf den Kopf! Ich hatte ja geschrieben das ich die Fehlermeldung nicht mehr genau weiß weil ich keinen Screenshot gemacht habe. In dem Link ist die genaue Fehlermeldung drin (für alle, die den genauen Wortlaut der Fehlermeldung gern wissen möchten).

Bei dieser Gelegenheit würde ich auch gerne nochmal auf diesen Beitrag hinweisen (Virenschutz für Hyperv-Server (Trend Micro Client Server Security)). Wie wir jetzt wissen bzw. erfahren mussten, ist es nicht ratsam einen Virenschutz zu installieren (es sei denn man installiert einen und führt Ausnahmen ein!).

Jan Kappen
 

Jan Kappen ist ausgebildeter Fachinformatiker in der Richtung Systemintegration. Er hat seine Ausbildung im Sommer 2008 abgeschlossen und arbeitete bis August 2018 bei der Rachfahl IT-Solutions GmbH & Co. KG. Seit September 2018 arbeitet er als Senior Netzwerk- und Systemadministrator bei einem großen mittelständischen Unternehmen im schönen Sauerland. Jan Kappen ist unter anderen MCITP Server Administrator, Enterprise Administrator und Enterprise Messaging Administrator 2010 sowie MCTS für System Center Virtual Machine Manager 2008, Windows Server 2008 Active Directory, Windows Server Virtualization und Windows Server 2008 Network Infrastructure. Seit 2015 wird Jan Kappen im Bereich "File System Storage" bzw. "Cloud & Datacenter Management" für seine Expertise und seine Community-Arbeit mit dem MVP Award von Microsoft ausgezeichnet.

  • hallo Jan,
    vielen Dank für diesen Beitrag. Ich kann aus meiner Sicht bestätigen, dass TrendMicro Officescan tatsächlich die Ursache dafür ist, dass die XML-Dateien beim Anlegen der Konfiguration einer Hyper-V-Maschine geändert oder gelöscht werden, wonach die genannte Fehlermeldung erscheint.

    Für Microsoft jedoch bedeutet das doch nichts anderes als: je nach Konfiguration wird ein Stück Code erzeugt, welches als Schadsoftware erkannt wird. Das reizt zum Nachdenken an…

    viele Grüße,
    Erik

  • >